TLS Support

TLS Support

What is TLS?

Transport Layer Security (TLS) is an internet protocol used to secure communications between a client and a server. Its most common usage is to provide encrypted connections between a website and a web browser. There are currently three versions of TLS: 1.0, 1.1, and 1.2.

What Version of TLS does your digital workplace support?

Prior to March 20, 2019 your digital workplace supported connections from browsers using  TLS 1.0, TLS 1.1, and TLS 1.2. After this date, support for TLS 1.0 was deprecated to align with industry best practices for security and data integrity. Communications using TLS 1.1 or higher is still supported.

How does TLS 1.0 deprecation impact your digital workplace

With the support of TLS 1.0 discontinued:

  • Your digital workplace cannot be accessed with browsers that do not support TLS 1.1 or higher.
  • Igloo LDAP Sync Tool (ILST) versions prior to version 3.2.0.0 no longer function.

How to identify the TLS version of your browser

Check your browser's TLS compatibility by visiting SSL Labs Test your browser tool. The Protocol Support box displays what version of TLS your current browser supports.

What to do if your browser does not support TLS 1.1 or higher

If your browser does not support TLS 1.1 or higher, an update to a newer version is needed.

Your digital workplace is compatible with the latest two versions of:

  • Microsoft Internet Explorer 11
  • Google Chrome
  • Mozilla Firefox
  • Safari (Mac OSX)

These supported browsers, all support TLS 1.1 or higher.

How to identify your ILST version

Locate your most recent ILST.log file, the version of the tool is listed on the first line.

What to do if you are using a version of ILST older than 3.2.0.0

Please update to the newest version of ILST


Viewed 125 times